Table of Contents

1 Introduction .................................................................................................................. 3
2 Developers’ System Requirements ............................................................................. 5
3 Installing SecureAssist ............................................................................................... 6
  3.1 Local installation ....................................................................................................... 7
  3.2 Remote Installation ................................................................................................. 8
4 Activate/Deactivate SecureAssist .............................................................................. 9
  4.1 Activate Trial License ............................................................................................... 9
  4.2 Activate Standard License ...................................................................................... 10
  4.2.1 Cigital SecureAssist release 2.3.5 or later ...................................................... 10
  4.2.2 Cigital SecureAssist release 2.3.4 and earlier ................................................ 11
  4.3 Deactivate Standard License .................................................................................. 17
  4.3.1 Cigital SecureAssist release 2.3.5 or later ...................................................... 17
  4.3.2 Cigital SecureAssist release 2.3.4 and earlier ................................................ 17
  4.4 Activate Enterprise License .................................................................................... 20
  4.5 Deactivate Enterprise License ............................................................................... 24
5 Upgrading SecureAssist ............................................................................................. 26
  5.1 Upgrade to Standard Edition ................................................................................... 26
  5.2 Upgrade to Enterprise Edition ............................................................................... 27
6 Starting SecureAssist .................................................................................................. 29
  6.1 SecureAssist Views ............................................................................................... 29
  6.2 Start the CSA Plug-in ............................................................................................. 30
7 Using SecureAssist ...................................................................................................... 32
  7.1 Review a File and View Results ........................................................................... 32
  7.1.1 Included .jsp files ............................................................................................. 32
  7.1.2 Grouping Results .............................................................................................. 33
  7.1.3 Markers in the Editing View ............................................................................. 33
  7.2 Resource Review .................................................................................................... 34
  7.2.1 Starting Review .................................................................................................. 34
  7.2.2 Export Results .................................................................................................. 37
  7.2.3 UI Features ....................................................................................................... 38
  7.3 SecureAssist Guidance ......................................................................................... 40
  7.4 Suppressing Issues ............................................................................................... 42
  7.4.1 Suppressing an Issue Using a Marker ............................................................... 42
  7.4.2 Suppressing using the Views ........................................................................... 42
  7.5 Review Suppressed Issues ..................................................................................... 43
  7.6 Un-suppress Issue .................................................................................................. 43
  7.7 Deactivating Rules ............................................................................................... 44
  7.7.1 Deactivate a Rule for a Session or File ............................................................. 44
  7.7.2 Reactivate a Rule ............................................................................................... 44
  7.7.3 Deactivate Rule Permanently .......................................................................... 45
  7.8 Statistics .................................................................................................................. 47
  7.8.1 Selecting the Statistics View ............................................................................. 47
  7.8.2 Statistics for a file ............................................................................................. 48
8 Configuration........................................................................................................52
  8.1 Preferences........................................................................................................52
  8.1.1 General Preferences Page.............................................................................52
  8.1.2 Filters Configuration Preferences Page.......................................................53
  8.1.3 Filter Information Dialog............................................................................54
  8.1.4 Filter Properties............................................................................................55
  8.1.5 Licensing Preferences Page..........................................................................56
  8.2 Markers.............................................................................................................57
  8.3 Views................................................................................................................58
  8.3.1 Issues List View ............................................................................................58
  8.3.2 Project Review View .....................................................................................60
  8.3.3 Guidance Search View..................................................................................61
9 Troubleshooting......................................................................................................62
About Cigital, Inc......................................................................................................64
1 Introduction

Training in secure code development is essential to build software engineers’ skills. However, if that training is not reinforced in day-to-day work, much of the information learned will be quickly lost.

Cigital SecureAssist (CSA) is a standard plug-in for Eclipse that helps developers with secure coding in two ways: first, it provides a simple way to look up secure coding guidance quickly, without leaving the IDE; second, whenever a developer opens or saves a file, it performs a quick review of the source in the file to identify security bugs. Those bugs are itemized by severity in the "Issue List" pane. When a developer clicks on one of those issues, that line of code is highlighted and the appropriate, contextual guidance is displayed in the IDE.

The goal of SecureAssist is to reinforce security training without forcing a developer to be aware of every instance for which they need guidance or interrupting their work. SecureAssist helps prevent bugs from entering the code base, and reduces the number of bugs found later through static and dynamic testing. It installs like any other plug-in and all processing and guidance happens on the desktop - no communication with a central server is required.
2 Developers’ System Requirements

Supported Operating Systems

- Microsoft® Windows® XP (32-bit)
- Microsoft® Windows® 7 (32-bit and 64-bit)

Supported Development Environments

- Eclipse IDE
  - Eclipse 3.2 (Callisto project)
  - Eclipse 3.3 (Europa project)
  - Eclipse 3.4 (Ganymede project)
  - Eclipse 3.5 (Galileo project)
  - Eclipse 3.6 (Helios project)
  - Eclipse 3.7 (Indigo project)
  - Eclipse 4.2 (Juno project) (Requires a minimum of JRE 1.6)
  - Eclipse 4.3 (Kepler project) (Requires a minimum of JRE 1.6)
- IBM® Rational® Application Developer
  - RAD 7.0
  - RAD 7.5
  - RAD 8.0
  - RAD 8.5
  - RAD 9.0
- MyEclipse 8.6, 9, 10 and 2013
- SpringSource Tool Suite™ IDE
  - STS 3.5

Execution Environment

- NOTE: Minimum memory allocated to the IDE
  - 512MB for file level review
  - 1024MB for Project Review
- Minimum JRE 1.5 (Windows XP, Windows 7)

Hardware Requirements

- 50MB of free disk space
- 1.5GB memory
3 Installing SecureAssist

3.1 Local installation

1. Download the plug-in, extract and save locally
2. Start Eclipse, then select Help > Install New Software…
3. In the Install/Update dialog, click Add…
4. In the Add Site dialog box, add a local update site
   a. Enter a name for the update site: SecureAssist
   b. Install the plug-in from “Local” by pointing to the location
      where you saved the plug-in. Your target will be the update
      folder.
   c. Click OK.
   d. Select the checkbox and click Next.
5. In subsequent dialogs, select the checkbox for SecureAssist and press Next.
6. Check I accept the terms of the license agreements, click Next
7. After successful installation, you will be asked to restart Eclipse.
   Click Yes.
3.2 Remote Installation

1. Start Eclipse, then select Help > Install New Software…
2. In the Install/Update dialog, click Add…
3. In the Add Site dialog box
   a. Enter a name for the update site: SecureAssist
   b. Enter the update link in Location
   c. Click OK.
   d. Select the checkbox and click Next.
4. In subsequent dialogs, select the checkbox for SecureAssist and press Next.
5. Check I accept the terms of the license agreements, click Next
6. After successful installation, you will be asked to restart Eclipse. Click Yes.
4 Activate/Deactivate SecureAssist

An activation process must be completed after installing SecureAssist Eclipse plug-in. The activation wizard is displayed on IDE start after successful plug-in installation. Process is very simple and takes few simple steps to complete.

This section describes licenses available as well as step-by-step instructions on how to activate/deactivate SecureAssist IDE plug-in. In order to upgrade your license please follow steps described in section 5

4.1 Activate Trial License

1. Select **Activate trial license** and click on **Activate**

2. Upon successful activation the below dialog box will appear with the number of days the license is valid.
3. SecureAssist can be used till the license expires. Once the license expires, it has to be upgraded to a standard or enterprise license to continue using SecureAssist.

4.2 Activate Standard License

4.2.1 Cigital SecureAssist release 2.3.5 or later

Note: Make sure that your computer has a working Internet connection. This connection is needed to activate and deactivate standard license.

1. Select **Activate standard license** in the activation dialog box

2. Enter email address used during license purchase and your activation key. Click Activate.

3. Once license is successfully activated all details of the license file are displayed in the SecureAssist licensing preference page.
4.2.2 Cigital SecureAssist release 2.3.4 and earlier

1. Select **Activate standard license** in the activation dialog box and click on the **Activate**.

2. Click on **Generate…** in order to generate an activation file.
3. Check **I accept the terms of the license agreement** and click **Confirm**.

4. Enter your Account Id and Activation Key provided by the Customer Success Coordinator. Click on **Generate**…
5. Save the file in the desired location.

![Save Activation Details In Folder]

6. Send the `csa.activation` file to Customer Success Coordinator to receive the license file.

7. Once you receive the license click on `Window -> Preferences`. Select `SecureAssist` and click on `Licensing`. Click on `Activate` to import the standard license.

![Preferences]

![Licensing]
8. Select Activate standard license

![Activation window](image)

**Activate the application**
In order to continue, you must activate your software.

**Thank you for installing Cigital SecureAssist!**

- **Activate standard license:** Activate your purchased standard license.
- **Activate enterprise license:** Activate the product using enterprise server

[Activate button]

9. In Standard License Activation dialog click **Import...**

![Standard License Activation window](image)

**Standard License Activation**
Activate your purchased product.

A valid license file is required to activate the product.

**Step 1:** Buy Cigital Secure.
Purchase or obtain an activation key.

**Step 2:** Obtain license file
Generate machine identification and email it to SecureAssistHelp@cigital.com.

**Step 3:** Import license file
Import license file.

[OK, Cancel buttons]

10. Select license file provided by the Customer Success Coordinator and click **Open**.
11. Once license is successfully imported all details of the license file are displayed in the SecureAssist licensing preference page.
4.3 Deactivate Standard License

The standard license on the plugin can be deactivated at any point of time.

4.3.1 Cigital SecureAssist release 2.3.5 or later

Note: Make sure that your computer has a working Internet connection. This connection is needed to activate and deactivate standard license.

1. Click on `Windows->Preferences->SecureAssist->Licensing`. Click on the De-Activate button.

![Image of Preferences window]

2. Click on Yes, if you are sure of deactivating license.

![Image of License De-Activation dialog]

3. Once the standard license is deactivated, SecureAssist will display Activation screen.

4.3.2 Cigital SecureAssist release 2.3.4 and earlier

1. Click on `Windows->Preferences->SecureAssist->Licensing`. Click on the De-Activate button.
2. Click on **Yes**, if you are sure of deactivating license.

3. SecureAssist will prompt the user to select a location to save the deactivation file. Select a desired location and click **OK**.
4. Once the standard license is deactivated, SecureAssist will switch back to Trial License.
4.4 Activate Enterprise License

1. Select **Activate enterprise license** option in the activation dialog box and click on the **Activate** button.

2. Check **I accept the terms of the license agreement** and click **Confirm**

3. Enter the server URL to activate the license and click on **Next**.
4. The plugin requires the user to accept the certificates the first time it establishes a connection to the server in case of an “https” connection. Verify the information and click on **Accept Certificates** to accept the certificates.

5. Enter a user ID to be associated with the license and click on **Next**.
6. A confirmation screen is displayed with the Server URL and User ID used to activate the enterprise license. Verify the information and click on **Activate** to activate enterprise license.
The enterprise license and the rulepacks are downloaded from the server. The enterprise license information can be viewed on the plugin by clicking on **Windows -> Preferences.** Select **SecureAssist** and click on **Licensing.**
4.5 Deactivate Enterprise License

The enterprise license on SecureAssist can be deactivated from the plugin at any point of time.

1. Click on Windows-&gt;Preferences-&gt;SecureAssist-&gt;Licensing. Click on the De-Activate button.

2. Click on Yes, if you are sure of deactivating the license.

3. The deactivation wizard will open. Click on Next.
4. Verify the Server URL and User ID that will be used to deactivate. Click on Deactivate.

5. Once the enterprise license is deactivated, SecureAssist switches back to Trial edition.
5 Upgrading SecureAssist

At any point of time SecureAssist license can be upgraded to a standard or an enterprise edition.

In order to upgrade the license go to Window -> Preferences on the tool bar and click on SecureAssist. Select Licensing and click on Activate.

5.1 Upgrade to Standard Edition

1. Click on Activate Standard License and click on Activate.
2. The Standard License Activation dialog should open. Follow the steps in section 4.2 to upgrade to a standard license.

5.2 Upgrade to Enterprise Edition

1. Click on Activate Enterprise License and click on Activate.

2. Check I accept the terms of the license agreement and click Confirm
3. The enterprise activation dialog will open. Follow from step number 3 in section 4.4 to complete the upgrade process.
6  Starting SecureAssist

6.1  SecureAssist Views

SecureAssist provides several views for different functions within the IDE. For SecureAssist to work, you must first open the SecureAssist views. A brief description of each view follows:

Issue List – Issue List view must be enabled for SecureAssist to function. This view displays the potential security bugs identified in the file that is active in the editing pane. This list updates automatically each time a file is opened or saved. Clicking on an issue in the Issue List will highlight that line of code in the editing window while simultaneously displaying appropriate secure coding guidance in the Guidance view. Alternatively, a user can double-click an issue in the Issue List to display the guidance in a pop-up window.

Guidance – If enabled, the Guidance view will display secure coding guidance on an issue selected in the Issue List.

Guidance Search – Allows a text search of SecureAssist guidance

Statistics – This view provides information to the user on the number and types of issues identified and reviewed.

Call Chain – When appropriate information is available, this view provides additional information on the selected issue to help a developer diagnose and remediate the issue.

Project Review – This view allows a user to have SecureAssist review an entire project rather than an individual project file. Project Review will therefore take longer to review an entire project than it will reviewing an individual file. Please note that SecureAssist is a standard IDE plug-in, and is therefore limited to use of the memory allocated to the IDE (512MB by default in Eclipse). If a user intends to use Project Review, it is recommended that the memory allocated to the IDE be increased to a minimum of 1GB.
6.2 Start the CSA Plug-in

1. In Eclipse, select Window -> Show View -> Other…

2. Expand the SecureAssist folder and select the desired view(s), then click OK.

NOTE: While there are several views available, the Issue List view must be enabled for SecureAssist to function.
3. In Eclipse, arrange the Views as desired. An example is shown below.
7  Using SecureAssist

Once the Issue List view is enabled, SecureAssist will work automatically as you work. There are no special actions required by a user. SecureAssist reviews files for security issues:

- Automatically, whenever a file is opened
- Automatically, whenever a file is saved.
- On demand, when using the Issues List view.

7.1  Review a File and View Results

When a user opens a file, SecureAssist automatically reviews that file for potential security bugs and populates the Issue List view. Clicking on any issue will bring the editor to the appropriate line in the file and populate the Guidance view, and issues can be examined to understand why the code was flagged.

7.1.1  Included .jsp files

If the file you have reviewed is a .jsp it may contain “include file” directives. If it does, an additional pane in the Issue List view will have an “Include Hierarchy”. This pane is intended to show that issues found during the .jsp file review may have issues found in the “included” files. In the example below the 3rd issue found is in the included file jsp3.jsp, which is recursively included.
7.1.2 Grouping Results

By default, results in the Issue List are sorted by Rule Importance (potential severity). Users may also sort the issues in the Issue List by Rule Category, Rule Title or Line Number as follows:

a. With the Issue List open, click on the Group By icon to display the drop down menu

b. Select Group By: -> Rule Category (or, as desired, Rule Importance, Rule Title, Line Number)

7.1.3 Markers in the Editing View

When a user clicks on an issue in the Guidance view, the editor will bring focus to the line of code indicated in the Issue List. A marker will be visible in the margin and the
issue will be highlighted. Hovering over a marker will display a brief description of the issue.

7.2 Resource Review

While the typical use of SecureAssist is a developer working on a single file, Resource Review allows a user to review an entire eclipse project or a resource for security bugs. Resource can be a package or folder in a project. This is typically performed as part of a group code review, as the files reviewed may belong to several developers.

NOTE: SecureAssist is an Eclipse plug-in. As such, it is limited to the memory allocated to Eclipse. Project Review will consume memory at a higher rate than a single file review. Depending on the size and complexity of the project, SecureAssist may not have access to sufficient memory to complete the review.

7.2.1 Starting Review

A resource can be reviewed either from the project review view or the context menu.

7.2.1.1 Project Review from project review view

The “Select Project” dropdown lists all the open projects in the workspace. A project can be selected from the drop down for project review. Click on the green arrow button to start project review.

7.2.1.2 Resource Review from context menu
The user has the ability to scan just a resource from the context menu of the project explorer, navigator in eclipse. The resource can be a project, package or folder. Multiple selections of packages and folder within the same project can also be reviewed.

Right click on the resource to be reviewed. Click on the menu item “Cigital Secure Assist → Review”.

The review of the selected project, package or folder starts in the project scan view.

SecureAssist computes the various kinds of the files that can be scanned and an estimated time to complete the review.

Estimated time is calculated based on the time selected for a single file scan in the project. The user can select anything between 20 seconds (min) to 60 seconds (max). If a files is not scanned completely within the time selected an error is reported in the review summary dialog once the scan is complete.
SecureAssist also notifies the user if any compilation errors exist in files that were selected for review. The findings in files with errors will not be accurate.

In order to get the list of files with errors, click on the hyperlink next to the count. A dialog box displays the name and the relative path of files which have errors.

Once review is complete, the results are displayed in the project review view in the order of severity of issues.
The “Review Summary” link displays the total number of files, the duration of the scan and the list of files with errors.

### 7.2.2 Export Results

Once the review is complete, the findings from the review can be exported to an XML file. Click on the icon “Export Results”.

The user is prompted to select the location where the results should be exported. The folder called “CSA-<Project-Name>” containing the results are saved in the selected location.
7.2.3 UI Features

7.2.3.1 Group Results

By default, results in the Project Review view are grouped by Rule Importance (potential severity). Users may also group the issues in the Project Review View by Package, Rule Category, Rule Title or File Name.

i. With the Project Review view open, click on the Group By icon to display the drop down menu.

ii. Select Group By: -> Rule Category (or, as desired, Rule Importance, Rule Title, Package, File Name)

7.2.3.2 Order Results

The results in the project review view can be sorted either in the descending or ascending order. By default, results in the Project Review View are sorted in descending order.

i. With the Project Review view open, click on the Order icon to display the drop down menu.

ii. Select Order: -> Ascending (or Descending)
7.2.3.3 Filter results

The user can type in text in the filter search box to display issues with matching package, rule title, rule category, filename and description.

The user also has the capability to use regex to search for matching text only in packages, rule title, rule category, or filename.

The below patterns can be used to search.

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>package=</td>
<td>Search for text only in package names</td>
</tr>
<tr>
<td>category=</td>
<td>Search for text only in rule category</td>
</tr>
<tr>
<td>title=</td>
<td>Search for text only in rule title</td>
</tr>
<tr>
<td>filename=</td>
<td>Search for text in file names</td>
</tr>
</tbody>
</table>
SecureAssist Guidance

The goal of SecureAssist’s guidance is to provide developers with concise, contextual information to help correct a security issue and get on with developing software. The guidance is not simply industry recommendations. Instead, Cigital has leveraged its base of nearly 150 practicing security experts and developed guidance based on thousands of code reviews.

Importantly, SecureAssist also understands the context in which the risk is introduced, and can provide guidance appropriate for that environment. A user doesn’t need to sift through information on .NET applications when she is working on a Java application.

In the (optional) Enterprise Server version, SecureAssist’s guidance and rules can be customized to meet internal standards.

The guidance includes the following sections:

- **Brief Description** – provides a high-level overview of the security issue.
- **Extended Description** – explains the issue in more detail.
- **How This Vulnerability Occurs** – provides examples of common ways the bug is exposed in software, along with descriptions of how an attacker might exploit the errors.
- **Preferred Code Examples** – offers mitigation strategies for the issue, including examples of how the incorrect examples can be remediated.
- **Recommendations** – provides a brief summary of the mitigation strategy.
- **Resources** – provides links to outside resources, including OWASP, CWE and other third-party organizations.

When a user clicks on an issue in Issue List view, the corresponding guidance will be displayed in the Guidance view. Alternatively, double-clicking an issue will display the guidance in a pop-up window. Users may also search for guidance using SecureAssist’s Guidance Search view.
Negative Code Example (Don’t Do This)

The following example simply echoes a variable back to the client. If the variable contains any malicious input tags, they will be interpreted (and executed) by the browser.

```html
<?php
    $email = request('get', 'email');
    echo $email;

    // Email Address: $email
```

Using the appropriate HTML output encoding, if the attacker submits:

```html
https://example.com/?email=exploit
```

This should be encoded into:

```html
https://example.com/?email=%23exploit
```

in order to prevent the execution of this attack by the browser.

Preferred Code Example

The next example wraps the XSLT `text()` tag, which HTML-encodes the data and defangs potentially dangerous HTML tags (e.g., `<script>` becomes `&lt;script&gt;`, for example). This is the preferred method for sending HTML output.

```html
<?php
    $email = http://example.com/set?email=foo;
    echo $email;

    // Email Address: <input value='$email'/>
```
7.4 Suppressing Issues

Occasionally, you will want to ignore or suppress an issue, and have it hidden from your view in SecureAssist. Suppressing and issue and deactivating a rule result in different behavior in Secure Assist:

Suppress Issue – will hide a specific issue from view for the remainder of the current Eclipse session

7.4.1 Suppressing an Issue Using a Marker

In the editing window, right-click on the marker in the ruler. Select Suppress Issue.

7.4.2 Suppressing using the Views

In the SecureAssist Issue List view or project review view, right-click on an issue and select Suppress Issue.
7.5 **Review Suppressed Issues**

To review suppressed issues, a user must first display the suppressed issues. In the SecureAssist Issue List view, right-click in the results and select **Show Suppressed Issues**.

7.6 **Un-suppress Issue**

Once the suppressed issues are reviewed, a user can choose to unsuppress and issue by right-clicking on the suppressed issue and selecting **Unsuppress Issue**.
7.7 Deactivating Rules

7.7.1 Deactivate a Rule for a Session or File

A user may choose to deactivate a rule for an individual file or for all files for the duration of the Eclipse session. To deactivate a rule, right-button click the target rule and select the appropriate option.

Deactivate a rule for a file – This command will turn off that single rule for that single file for the current Eclipse session. If Eclipse is closed and restarted, the rule will be reactivated.

Deactivate a rule for a session – This command will turn off that single rule across all files for the current Eclipse session. If Eclipse is closed and restarted, the rule will be reactivated.

7.7.2 Reactivate a Rule

To reactivate a rule, right-button click in the Issue List view and select the rule to reactivate.
7.7.3 Deactivate Rule Permanently

SecureAssist was designed to help developers improve their secure coding skills and includes many rules to cover common software security vulnerabilities. However, some users may find some rules unnecessary. To deactivate a rule:

1. Select Window -> Preferences…

2. In the preferences tree select Cigital SecureAssist -> Filters Configuration. Select the filter (set of rules) you wish to modify, and select Modify.
3. The filter information dialog will appear. In the filter information tree, select the rule you would like to disable. Uncheck the checkbox next to the rule’s name on the list and select **Save**.
7.8 Statistics

The Statistics view in SecureAssist displays graphic representations of the finding in both files and projects. There are four tabs available in the Statistics view:

- **File Information** – Information about the file being reviewed, including Project Name, Package Name, Lines of Code and the date it was last reviewed by SecureAssist.
- **Reviewed** – A pie chart showing the number of issues identified by SecureAssist, and how many of those issues have been reviewed by the developer.
- **LOC** – A line graph showing the number of lines of code and issues identified, over time.
- **Issues Lifetime** – A graph representing the lifetime of an issue (issue introduced in the file -> issue fixed in the file)

7.8.1 Selecting the Statistics View

If the Statistics view is not visible in SecureAssist, Go to Window -> Show View -> Other… Select Statistic under Show View.
7.8.2 Statistics for a file

The **File Information** tab displays generalize information about the selected file, including Project Name, Package, File Name, Lines of code and SecureAssist scan information.

The **Reviewed** tab displays a pie chart representing the number of issues reviewed versus the number of issues not reviewed.
The **LOC** tab displays the total number of issues and total lines of code in the file over time.

The **Issues Lifetime** tab displays the individual issues in a file, over time. When an issue is added, a marker will appear corresponding to the issue ID on the left. When an issue is resolved, its marker will disappear.
7.8.3 **Statistics for a project**

After running Project Review, the **Files** tab in Statistics will display a pie chart showing the total number of files in the project versus the number of files that have been opened and reviewed by a developer.

The **File by Type** tab will display a bar graph detailing the various file types in the project, and also the number of files reviewed in each file type.
8 Configuration

8.1 Preferences

8.1.1 General Preferences Page

<table>
<thead>
<tr>
<th>General Settings</th>
<th>Custom filters have priority</th>
<th>If checked, when a custom and default rule are both active, the custom rule will have priority.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Inform about license expiration</td>
<td>Allows the user to set an informational notice N days prior to the SecureAssist license expiration date.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Review Settings</th>
<th>Review on File Save</th>
<th>If checked, SecureAssist will review a file whenever it is saved (default).</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Review on File Open</td>
<td>If checked, SecureAssist will review a file whenever it is opened (default).</td>
</tr>
</tbody>
</table>

| Project Review                   | Default time for the single file scan | Number of seconds that will be spent to scan a single file during project review. |
8.1.2 Filters Configuration Preferences Page

<table>
<thead>
<tr>
<th>Filter Settings Table</th>
<th>A table displaying list of available filters. Filters that are “checked” will be used to identify potential issues.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description Text Area</td>
<td>A short description of the currently selected filter.</td>
</tr>
<tr>
<td>Modify Button</td>
<td>Opens the filter modification dialog, allowing user to modify filter rule settings.</td>
</tr>
<tr>
<td>Properties Button</td>
<td>Opens the filters properties dialog.</td>
</tr>
<tr>
<td>Import Button</td>
<td>Opens the file selection dialog, which allows users to import new custom filters. Imported filters are marked as custom.</td>
</tr>
</tbody>
</table>
### 8.1.3 Filter Information Dialog

#### Filter Information
- **Filter information tree**: A list of rules in the selected filter. Rules are active if the checkbox is “checked”. To deactivate a rule, “uncheck” the box for that rule.

#### Rule Information
- **Rule Title**: The title of the currently selected rule
- **Rule Language**: Currently selected rule language (Java, JSP, XML, FTL)
- **Rule Category**: Currently selected rule category.
- **Rule Description**: Currently selected rule description.

#### Rule Configuration
- **Show marker in text**: If selected, issues identified by that rule will include a Cigital marker in the editor view.
- **Rule Importance**: Rule criticality: LOW, MEDIUM, HIGH
- **Save Button**: Saves changes made to the rule configuration to the filter XML file.
8.1.4 Filter Properties

<table>
<thead>
<tr>
<th>Filter Type</th>
<th>Default – A filter/rule provided by Cigital</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Custom – A filter/rule modified by the user, imported</td>
</tr>
<tr>
<td>Filter Location</td>
<td>Location of the filter on the hard drive</td>
</tr>
<tr>
<td>Filter Name</td>
<td>Filter name</td>
</tr>
<tr>
<td>Filter Version</td>
<td>Filter version</td>
</tr>
<tr>
<td>Filter Description</td>
<td>Short filter description</td>
</tr>
</tbody>
</table>
## 8.1.5 Licensing Preferences Page

### License Key Information

<table>
<thead>
<tr>
<th>License Key Information</th>
<th>Product</th>
<th>The name of the product covered by this license</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Version</td>
<td>The current version number</td>
</tr>
<tr>
<td></td>
<td>Exp. Date</td>
<td>The expiration date of license key</td>
</tr>
</tbody>
</table>
### 8.2 Markers

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>High Importance Issue Marker</td>
<td>Marker used for issues discovered using rules with importance set to HIGH</td>
</tr>
<tr>
<td>Medium Importance Issue Marker</td>
<td>Marker used for issues discovered using rules with importance set to MEDIUM</td>
</tr>
<tr>
<td>Low Importance Issue Marker</td>
<td>Marker used for issues discovered using rules with importance set to LOW</td>
</tr>
<tr>
<td>High Importance Issue</td>
<td>Marker for suppressed issues for rules with importance set to HIGH</td>
</tr>
<tr>
<td>Suppression Marker</td>
<td></td>
</tr>
<tr>
<td>Medium Importance Issue</td>
<td>Marker for suppressed issues for rules with importance set to MEDIUM</td>
</tr>
<tr>
<td>Suppression Marker</td>
<td></td>
</tr>
<tr>
<td>Low Importance Issue</td>
<td>Marker for suppressed issues for rules with importance set to LOW</td>
</tr>
<tr>
<td>Suppression Marker</td>
<td></td>
</tr>
</tbody>
</table>
8.3 Views

8.3.1 Issues List View

Search is done on category and description of rules that were used to discover issues

- Review File
- Expands issues tree
- Collapses issues tree
- Opens Report Bug dialog
- Clears all issues from the issues list as well as all markers in the editor.

8.3.1.1 Pop-up menu
### Suppress Issue
Suppresses the currently selected issue

### Unsuppress Issue
Unsuppresses the currently selected suppressed issue

### Show Suppressed Issues
Show/hide suppressed issues

### Deactivate Rule for Session
Deactivates the selected rule for the current session across all files

### Deactivate Rule for File
Deactivates the selected rule for the current file for the current session

### Activate Rules For Sessions
Reactivates deactivated rules across all files for the current session (Available only if at least one rule is deactivated)

### Activate Rules For File
Reactivates deactivated rules for the current file for current session (Available only if at least one rule is deactivated)

#### 8.3.1.2 Group By for Issue List

**Group By:** Groups results by:
- Rule Description
- Rule Importance
- Rule Title
- Line Number
8.3.2  Project Review View

Search is done on results in the view
Review a resource
Stop resource review
Show previous issue in the issue list
Show next issue in the issue list
Expands issues tree
Collapses issues tree
Export results to an XML file
Select project for review
Opens Report Bug dialog

8.3.2.1  Group By for Project Review

Group By:

Groups results by:

- Package Name
- Rule Category
- Rule Importance
- Rule Title
- File Name
8.3.2.2 Order for Project Review

Group By: Order results by:
- Ascending
- Descending

8.3.3 Guidance Search View

The Guidance Search will search across the guidance filepaths, file names, short descriptions and long descriptions. This will also accept more advanced search types, such as:

- Filename: <filter text>
- Title: <filter text>
- Description: <filter text>

Clear filter text
9 Troubleshooting

For any issues regarding use of the CSA Plug-in, contact technical support at SecureAssistHelp@cigital.com.

Reporting a Bug

To send a short email from Eclipse, select Report Bug to open the Report Bug Dialog.

1. Press Send.

2. Your default e-mail client will open with email information automatically entered. Replace the [Please Enter Message Here] text with any comments or details you would like to add. Send the email from the e-mail client.
**Error message: Please select at least one filter to be used**

Go to Preferences -> Cigital SecureAssist -> Filters Configuration and make sure that you have selected at least one filter from the list of available filters. If filters list is empty make sure that you have rulepack update site set up and you have had performed successful rulepack update.

**Error message: The file could not be Reviewed.**

There are three most common reasons for this message to appear:

1) Your classpath is incorrect and type bindings cannot be resolved. (Make sure that you do not have any unresolved imports in file)

2) Your project is set up incorrectly (Import your projects as language specific projects, and make sure that files are in source folders)

3) Your file is too large or complex for the available memory allocated to the IDE, and the plug-in is unable to Review it.
About Cigital, Inc.

Cigital, Inc., a leading software security and quality consulting firm, was established in 1992 with a single focus of helping organizations improve software. Our consultants are thought leaders who specialize in programs that help organizations ensure their applications are secure and reliable while also improving how they build and deploy software. We provide advice across the enterprise using a combination of proven methodologies, tools, and best practices that are tuned to meet each client's unique requirements. Cigital has enabled some of the most well-known organizations in financial services, communications, insurance, hospitality, e-commerce and government to reduce their mission-critical software business risks. Cigital is headquartered near Washington, D.C. with regional offices in the U.S., Europe and India.